Project

General

Profile

Bug #3827

Missing maxlength parameter in firewall_aliases_edit.php

Added by Julien Le Goff almost 4 years ago. Updated over 3 years ago.

Status:
Rejected
Priority:
Normal
Assignee:
-
Category:
-
Target version:
-
Start date:
08/25/2014
Due date:
% Done:

0%

Affected Version:
2.1.x
Affected Architecture:

Description

Seen on 2.1.4, when creating an alias with a name longer than 31 chars, the following notice appears :

[ There were error(s) loading the rules: /tmp/rules.debug:210: table name too long, max 31 chars - The line in question reads [210]: table { x.x.x.x } ]

The "size" parameter of the "name" field is set to 40 in the form, but the "maxlength" is missing (should be set to 31 if that's the real cause firing the notice).

Associated revisions

Revision eab05c00
Added by Renato Botelho almost 4 years ago

Alias name cannot have more than 31 chars, add maxlength here just as an extra check. Ticket #3827

Revision ab6558b6
Added by Renato Botelho almost 4 years ago

Alias name cannot have more than 31 chars, add maxlength here just as an extra check. Ticket #3827

History

#1 Updated by Renato Botelho almost 4 years ago

Could you share the name you tried to add? I couldn't reproduce it.

#2 Updated by Julien Le Goff over 3 years ago

Sorry I didn't have the full info, the aliases were actually created via an XML import and are named like this : clients_datacenter_server1web_lan

Maybe the restore function could check the name length then and prevent the creation of aliases too long ?

#3 Updated by Renato Botelho over 3 years ago

  • Status changed from New to Rejected

Restore function only copy config.xml file to the correct place and reboot the system. Your xml is broken, maybe manually edited. Then it's not a bug in pfSense.

Also available in: Atom PDF