Project

General

Profile

Actions

Bug #3836

closed

field redirect target port must be quit in a specific way to keep conntent

Added by Stefan Beckers about 7 years ago. Updated over 5 years ago.

Status:
Resolved
Priority:
Normal
Assignee:
-
Category:
Web Interface
Target version:
Start date:
08/29/2014
Due date:
% Done:

0%

Estimated time:
Plus Target Version:
Release Notes:
Affected Version:
All
Affected Architecture:

Description

When in
  • Firewall: NAT: Port Forward: Edit

and trying to add/edit a rule, the value in the Redirect target port field I have got the impression that the first value entered/autofilled (especially when using aliases) is staying in the field.

I figured out that leaving the filed by
  • clicking in some other fields in the form
  • going further using "RETURN" key
  • using TAB Key

do reset the field back to the first value being entered.

If you leave the field by using SHIFT-TAB, the value is kept. There might also be other ways to keep the last value.

If you have multiple aliases which are the same in the first characters you might ending up not noticing the reversion of the contents and you are wondering why the form does not save.

I can remember that this has cost me quite a bit of time one or two years before. So this bug seems to be in pfSense for quite a while.

Actions #1

Updated by Chris Buechler over 6 years ago

  • Status changed from New to Confirmed
Actions #2

Updated by Chris Buechler over 5 years ago

  • Status changed from Confirmed to Resolved
  • Target version set to 2.3

fixed in bootstrap conversion

Actions

Also available in: Atom PDF