Project

General

Profile

Bug #389

"LDAP Authentication container" Select doesn't work until after Save

Added by Chris Buechler about 9 years ago. Updated almost 9 years ago.

Status:
Resolved
Priority:
Normal
Assignee:
-
Category:
User manager
Target version:
Start date:
03/01/2010
Due date:
% Done:

0%

Estimated time:
Affected Version:
2.0
Affected Architecture:

Description

Upon initially filling in the fields appropriately on system_usermanager_settings.php for LDAP, and clicking the Select button next to "LDAP Authentication container", you get:

Sorry, we could not connect to the LDAP server. Please try later.

It works when clicking Select after clicking Save, but not before those settings are saved. It should work before it's saved as well.

Associated revisions

Revision 7a938f1b (diff)
Added by Ermal Luçi about 9 years ago

Ticket #389. Correctly make the ldap object picker work and handle various errors.

History

#1 Updated by Ermal Luçi about 9 years ago

  • Status changed from New to Feedback

Solved by today commits.

#2 Updated by Chris Buechler about 9 years ago

  • Status changed from Feedback to New

Now when clicking Select, in the pop up window you get:

Warning: ldap_search(): Search: Operations error in /etc/inc/auth.inc on line 632 Warning: ldap_get_entries(): supplied argument is not a valid ldap result resource in /etc/inc/auth.inc on line 633
Please select which containers to Authenticate against:

and it doesn't list anything.

#3 Updated by Ermal Luçi about 9 years ago

Was any of the option needed to display the settings empty?

#4 Updated by Ermal Luçi about 9 years ago

  • Status changed from New to Feedback

#5 Updated by Chris Buechler almost 9 years ago

  • Status changed from Feedback to Resolved

Also available in: Atom PDF