Project

General

Profile

Bug #4111

Unbound replies using wrong source IP when bound to *

Added by Chris Buechler almost 6 years ago. Updated almost 6 years ago.

Status:
Resolved
Priority:
Normal
Assignee:
-
Category:
DNS Resolver
Target version:
Start date:
12/13/2014
Due date:
% Done:

0%

Estimated time:
Affected Version:
2.2
Affected Architecture:

Description

When Unbound is bound to all interfaces, it replies back with the source IP it would use for initiating a new connection rather than the IP where the original request was destined.

Adding the following to unbound.conf fixes:

interface-automatic: yes

Unbound's documentation calls that "experimental", though it works fine in every circumstance I can think of.

The one caveat to this is if you're restricting binding of Unbound, and set "interface-automatic: yes", Unbound actually binds to *:53. So only going to set this where it's already binding to *.

Associated revisions

Revision f358fe3f (diff)
Added by Chris Buechler almost 6 years ago

Where binding Unbound to *:53, set "interface-automatic: yes" so replies are sourced from the correct IP. Ideally this should always work this way, but setting this causes Unbound to bind to *:53, which shouldn't happen where specific interfaces are chosen. Ticket #4111

Revision 7dd5f0f7 (diff)
Added by Chris Buechler almost 6 years ago

Where binding Unbound to *:53, set "interface-automatic: yes" so replies are sourced from the correct IP. Ideally this should always work this way, but setting this causes Unbound to bind to *:53, which shouldn't happen where specific interfaces are chosen. Ticket #4111

History

#1 Updated by Chris Buechler almost 6 years ago

  • Status changed from Confirmed to Feedback

Fix committed and verified for the circumstance where binding all interfaces.

#2 Updated by Chris Buechler almost 6 years ago

  • Status changed from Feedback to Resolved

If not ideal since it only completely fixes the circumstance where you're binding to *:53, this is the best we can do here given constraints of Unbound.

Also available in: Atom PDF