Project

General

Profile

Bug #4117

Using run(4) USB WLAN in hostap mode crashes in FreeBSD 10.x

Added by Andreas Mueller over 4 years ago. Updated over 4 years ago.

Status:
Resolved
Priority:
High
Assignee:
-
Category:
Operating System
Target version:
Start date:
12/15/2014
Due date:
% Done:

0%

Estimated time:
Affected Version:
2.2
Affected Architecture:

Description

I was using a "Hama Wireless LAN USB 2.0 Stick 300 Mbps" for some time as an access point with the 2.2 alpha and beta nightly builds. In 2.1 there have been some issues with the run(4) driver which have been fixed in newer FreeBSD releases, that's why I was using the newer nightlies. The setup was working pretty stable. I've decided to upgrade to 2.2-RC, but now using the USB WLAN will result in a kernel crash. After upgrading my system ended up in an infinite crash-reboot-loop.

After removing the USB WLAN device I was able to copy some trace output from the error report in the web frontend (see attached file).

The problem is also reproducible on other systems (using the same USB WLAN) booting from a 2.2-RC live system.

I hope this issue can be fixed in the 2.2 release.

pfsense_crash.txt (324 KB) pfsense_crash.txt Andreas Mueller, 12/15/2014 03:41 PM

History

#1 Updated by Chris Buechler over 4 years ago

  • Status changed from New to Rejected

please replicate on stock FreeBSD 10.1 and report upstream, that's a driver issue outside of our control.

#2 Updated by Andreas Mueller over 4 years ago

I am not able to reproduce this crash on FreeBSD 10.1.

Using the FreeBSD kernel on the pfSense installation works as well.

#3 Updated by Chris Buechler over 4 years ago

it's crashing in run and we include 100% stock run(4) and don't patch anything related to wifi, there is more of a diff there in the testing somewhere. Replacing our kernel with a stock FreeBSD kernel will break a variety of things that leaves you with no packet filter and potentially a variety of other differences, though not sure that'd be related. The crash report makes me suspect a difference in something to do with channel configuration where it crashes and where it doesn't.

#4 Updated by Chris Buechler over 4 years ago

  • Subject changed from Using run(4) USB WLAN as hostap crashes pfSense 2.2-RC to Using run(4) USB WLAN in hostap mode crashes in FreeBSD 10.x
  • Category set to Operating System
  • Status changed from Rejected to Feedback
  • Target version set to 2.2.1

There is a fix for this upstream, so we've imported it.

this is the bug: https://bugs.freebsd.org/bugzilla/show_bug.cgi?id=189405

I imported that patch into our builds, so it should be fixed in 2.2.1.

#5 Updated by Chris Buechler over 4 years ago

  • Status changed from Feedback to Resolved

confirmed resolved

Also available in: Atom PDF