Project

General

Profile

Bug #4454

scrub random-id + PPPoE + IPsec + communication to LAN IP = kernel panic on 32 bit

Added by Vladimir Putin over 4 years ago. Updated almost 4 years ago.

Status:
Duplicate
Priority:
Normal
Assignee:
-
Category:
IPsec
Target version:
-
Start date:
02/20/2015
Due date:
% Done:

0%

Estimated time:
Affected Version:
Affected Architecture:
i386

Description

Started almost here https://forum.pfsense.org/index.php?board=16.0
But I am not sure is it all have the same reason to panic
For me it is reproducible. I have configured WAN as PPPoE and LAN too, also I have "Insert a stronger id into IP header of packets passing through the filter." enabled. If I create mobile client tunnel in IPSEC, no matter wich way it's created, I can connect successfully, but if I try to open pfsense homepage via LAN address, then pfsense immediately crashes, sometimes it crashes right after ipsec connection is up. If I disable Insert a stronger id into IP header of packets passing through the filter." option in pfsense, then ipsec works and no more kernel panics.


Fatal double fault:
eip = 0xc0da5cd2
esp = 0xe0783fd0
ebp = 0xe0784114
cpuid = 1; apic id = 01
panic: double fault
cpuid = 1
KDB: enter: panic

crash.txt (417 KB) crash.txt crash dump Vladimir Putin, 02/20/2015 10:13 AM

History

#1 Updated by Chris Buechler over 4 years ago

  • Subject changed from Some configuration options and IPSEC simultaneously — kernel panic to scrub random-id + PPPoE + IPsec + communication to LAN IP = kernel panic on 32 bit
  • Status changed from New to Confirmed
  • Priority changed from High to Normal
  • Affected Architecture set to i386

subject updated to what appears to be the specific issue here. this is a very unusual circumstance. The other issues in the linked thread seem different, will create a separate ticket there after narrowing down what that problem is.

#2 Updated by Chris Buechler almost 4 years ago

  • Status changed from Confirmed to Duplicate

this is a duplicate of #4754, which has better info

#3 Updated by Chris Buechler almost 4 years ago

  • Affected Version deleted (2.2)

Also available in: Atom PDF