Project

General

Profile

Bug #4679

IPsec dashboard widget wrongly shows "REKEYED" SAs as "down"

Added by Chris Buechler over 4 years ago. Updated over 4 years ago.

Status:
Resolved
Priority:
Normal
Assignee:
-
Category:
IPsec
Target version:
Start date:
05/05/2015
Due date:
% Done:

0%

Estimated time:
Affected Version:
2.2.x
Affected Architecture:

Description

Where you have an SA in status REKEYED in 'ipsec statusall', similar to:

con22003{2509}:  REKEYED, TUNNEL, reqid 23, expires in 66 seconds

The dashboard widget counts those as down connections. There are newer, active SAs in place for the same P2s that are counted as up. So you end up with the status showing more connections than actually exist.

History

#1 Updated by Chris Buechler over 4 years ago

  • Status changed from Confirmed to Resolved
  • Affected Version changed from 2.2 to 2.2.x

the REKEYED entries no longer exist since that separate bug was fixed, which leaves this fine.

Also available in: Atom PDF