Project

General

Profile

Actions

Bug #473

closed

pftop no longer functions

Added by Chris Buechler over 11 years ago. Updated over 11 years ago.

Status:
Resolved
Priority:
Normal
Assignee:
-
Category:
-
Target version:
Start date:
04/03/2010
Due date:
% Done:

0%

Estimated time:
Plus Target Version:
Release Notes:
Affected Version:
2.0
Affected Architecture:

Description

Attempting to run it results in:
pftop: DIOCGETSTATUS: Permission denied

# ls -l /dev/pf
crw-rw----  1 root  proxy    0,  76 Apr  2 16:22 /dev/pf

proxy group has no members on my installs (don't think it should as there aren't any packages installed). Others have reported duplicate proxy groups.
http://forum.pfsense.org/index.php/topic,24052.0.html

Actions #2

Updated by Fernando Lemos over 11 years ago

In FreeBSD 8.0, pftop, pftpx and ftp-sesame all fail. The problem is that the DIOCGETSTATUS ioctl fails with ENODEV (no idea why). I think this is exactly the problem described in this bug report.

Actions #3

Updated by Fernando Lemos over 11 years ago

Recompiling pftop solved it. I think DIOCGETSTATUS changed recently (why?), so the switch never got to DIOCGETSTATUS, and the default action is to return ENODEV in that case. It'll probably be fixed as soon as the binaries are recompiled, if it's not fixed already.

Actions #4

Updated by Michel Kenny over 11 years ago

I just tried the latest build (20100420-054) and it is now working. It was not working as of a few days ago.

Actions #5

Updated by Chris Buechler over 11 years ago

  • Status changed from New to Resolved

Yeah it's been fixed

Actions

Also available in: Atom PDF