Project

General

Profile

Bug #4808

Unbound segfaults

Added by Mark Janssen over 3 years ago. Updated over 2 years ago.

Status:
Closed
Priority:
High
Assignee:
-
Category:
DNS Resolver
Target version:
-
Start date:
07/01/2015
Due date:
% Done:

0%

Estimated time:
Affected Version:
Affected Architecture:

Description

On one of my pfSense boxes I've seen Unbound segfault a couple of times. Since pfSense doesn't seem to monitor Unbound, it will not automatically restart and will thus require manual intervention. pfSense is running in a VM on a box with ECC memory, so I highly doubt this is a hardware issue.

Example log lines are:
- kernel: pid 8272 (unbound), uid 59: exited on signal 11
- kernel: pid 22346 (unbound), uid 59: exited on signal 11
- I think I've also seen a signal 10 once

Affected versions are all 2.2.x releases so far.

If there is a way to collect more information, I'd be happy to do so.

Related forum post: https://forum.pfsense.org/index.php?topic=94045

History

#1 Updated by Chris Buechler over 3 years ago

  • Status changed from New to Feedback

is there any means of replicating?

#2 Updated by Mark Janssen over 3 years ago

Unfortunately not, it seems to crash rather randomly. I'd love to be able to capture a stacktrace or other useful information.

#3 Updated by Steve Thomas over 3 years ago

Mark Janssen wrote:

Unfortunately not, it seems to crash rather randomly. I'd love to be able to capture a stacktrace or other useful information.

+1, crashed randomly on amd64 for me as well on several different devices

#4 Updated by Chris Buechler over 2 years ago

  • Status changed from Feedback to Closed
  • Affected Version deleted (2.2.3)

haven't seen any reports of this in >=2.3. The root cause is an issue in unbound itself, and several potential segfaults in it have been fixed in their releases since then.

Also available in: Atom PDF