Project

General

Profile

Actions

Bug #4927

closed

Add MAC only once to the pass-through list

Added by Markus Golser over 6 years ago. Updated over 6 years ago.

Status:
Not a Bug
Priority:
Normal
Assignee:
-
Category:
-
Target version:
-
Start date:
08/10/2015
Due date:
% Done:

0%

Estimated time:
Plus Target Version:
Affected Version:
Affected Plus Version:
Affected Architecture:

Description

I'm using pfsense and the captive portal.

If an user enters a voucher he is added to the Pass-through MAC list.

The issue is he can enter the voucher multiple times and the MAC is added multiple times to the Pass-through list.

I think the entry should be updated and not added a new one.

I have some MAC-Adresses 4 or 5 times on the list.

Actions #1

Updated by Kill Bill over 6 years ago

This does not belong under packages, plus a feature request, not a bug.

Actions #2

Updated by Markus Golser over 6 years ago

It is a feature not having multiple passthrumac entries?

Actions #3

Updated by Kill Bill over 6 years ago

Clearly there are many use cases where limiting users to one device is undesired. Should be something bound to "Disable concurrent logins", not enforced by default on everyone. If you always "update" the entry instead of doing additional checks, that just breaks those use cases.

Actions #4

Updated by Chris Buechler over 6 years ago

  • Status changed from New to Not a Bug
  • Affected Version deleted (2.2.3)

RADIUS with no concurrent logins enabled is the answer here. The built-in voucher system isn't intended for that type of usage. RADIUS can be treated as vouchers.

Actions

Also available in: Atom PDF