Project

General

Profile

Bug #4932

Avahi package fails to start after reboot since 2.2.3

Added by Chad Wagner almost 5 years ago. Updated almost 5 years ago.

Status:
Not a Bug
Priority:
Normal
Assignee:
-
Category:
Avahi
Target version:
-
Start date:
08/13/2015
Due date:
% Done:

0%

Estimated time:
Affected Version:
Affected Architecture:

Description

on a fresh 2.2.4 AMD 64 install (Hyper-V VM) Avahi fails to start after reboot.

Running this command will get the daemon started after initial boot.
/usr/local/etc/rc.d/avahi-daemon.sh restart
output is:
dbus not running? (check /var/run/dbus/dbus.pid).
dbus not running? (check /var/run/dbus/dbus.pid).
Starting dbus.

The service then works normally until the next reboot.

I checked to see if the var/run/dbus directory existed after boot and it is there.

Log after reboot:

Aug 12 23:00:43 root: /usr/pbi/avahi-amd64/etc/rc.d/dbus: WARNING: failed to start dbus
Aug 12 23:00:44 login: login on ttyv0 as root
Aug 12 23:00:44 sshlockout90767: sshlockout/webConfigurator v3.0 starting up
Aug 12 23:00:48 avahi-daemon1130: Found user 'avahi' (UID 558) and group 'avahi' (GID 558).
Aug 12 23:00:48 avahi-daemon1130: Successfully dropped root privileges.
Aug 12 23:00:48 avahi-daemon1130: avahi-daemon 0.6.31 starting up.
Aug 12 23:00:48 avahi-daemon1130: WARNING: No NSS support for mDNS detected, consider installing nss-mdns!
Aug 12 23:00:48 avahi-daemon1130: dbus_bus_get_private(): Failed to connect to socket /var/run/dbus/system_bus_socket: No such file or directory
Aug 12 23:00:48 avahi-daemon1130: WARNING: Failed to contact D-Bus daemon.
Aug 12 23:00:48 avahi-daemon1130: avahi-daemon 0.6.31 exiting.
Aug 12 23:00:48 avahi-daemon1660: Found user 'avahi' (UID 558) and group 'avahi' (GID 558).
Aug 12 23:00:48 avahi-daemon1660: Successfully dropped root privileges.
Aug 12 23:00:48 avahi-daemon1660: avahi-daemon 0.6.31 starting up.
Aug 12 23:00:48 avahi-daemon1660: WARNING: No NSS support for mDNS detected, consider installing nss-mdns!
Aug 12 23:00:48 avahi-daemon1541: Found user 'avahi' (UID 558) and group 'avahi' (GID 558).
Aug 12 23:00:48 avahi-daemon1541: Successfully dropped root privileges.
Aug 12 23:00:48 avahi-daemon1541: open(/var/run/avahi-daemon//pid): File exists
Aug 12 23:00:48 avahi-daemon1541: Failed to create PID file: File exists
Aug 12 23:00:48 avahi-daemon1660: dbus_bus_get_private(): Failed to connect to socket /var/run/dbus/system_bus_socket: No such file or directory
Aug 12 23:00:48 avahi-daemon1660: WARNING: Failed to contact D-Bus daemon.
Aug 12 23:00:48 avahi-daemon1660: avahi-daemon 0.6.31 exiting.

May be similar to:
https://redmine.pfsense.org/issues/2535

See this thread:
https://forum.pfsense.org/index.php?topic=96218.15

doktornotor has already made all of the style corrections to the package and cleaned it up. A checkbox is available to disable dbus which allows the service to start but I thought I should submit a bug since the package was working fine for me prior to 2.2.3 and I am not sure of the importance of dbus for proper package function.

Thanks,
Chad

History

#1 Updated by Chad Wagner almost 5 years ago

This only occurs for me in a Hyper-V virtual machine. I was using 2012 R2. I re-installed on bare metal and restored my config and no longer have to turn dbus off in order to get the service to start at bootup. I was running bare metal on 2.2.3 when it was working so I am pretty sure this is only related to Hyper-V.

#2 Updated by Chris Buechler almost 5 years ago

  • Status changed from New to Not a Bug

Thanks for the follow up. Hyper-V has some timing issues especially during initial bootup of the VM (often see a slew of "runtime went backwards" logs, which is the indication of that occurring). I'm guessing that's the actual root cause from the sounds of it.

Also available in: Atom PDF