Project

General

Profile

Bug #4950

TCP flags on firewall_rules_edit.php need formatting help

Added by Chris Buechler over 4 years ago. Updated about 4 years ago.

Status:
Resolved
Priority:
Normal
Target version:
-
Start date:
08/17/2015
Due date:
% Done:

0%

Estimated time:
Spent time:

Description

The existing arrangement of TCP flags on firewall_rules_edit.php makes it reasonably clear what's what (attached). Pick the flags to match, out of some list of flags. When checking "any", the other boxes all disappear, since they're not relevant.

The current bootstrap firewall_rules_edit.php shows a long list that doesn't visibly make sense. Also doesn't disable or hide the individual checkboxes when "any" is checked.

fw-rules-edit-TCP-flags.png (8.17 KB) fw-rules-edit-TCP-flags.png Chris Buechler, 08/17/2015 10:10 PM

History

#1 Updated by Steve Beaver over 4 years ago

  • Status changed from Confirmed to Resolved

Flag presentation (and advanced options in general) were horrible. Correct formatting has been restored, new javascript functionality provided, and an "Advanced options" button placed at the bottom of the form.

#2 Updated by Chris Buechler over 4 years ago

  • Status changed from Resolved to Feedback

#3 Updated by Steve Beaver over 4 years ago

  • Assignee set to Chris Buechler

#4 Updated by Chris Buechler about 4 years ago

  • Status changed from Feedback to Resolved

much, much improved on the advanced stuff in general.

this is fixed

Also available in: Atom PDF