Project

General

Profile

Bug #4952

Double click to edit is gone

Added by Chris Buechler almost 4 years ago. Updated over 3 years ago.

Status:
Resolved
Priority:
Low
Assignee:
Target version:
Start date:
08/17/2015
Due date:
% Done:

0%

Estimated time:

Description

Most screens allow double clicking an entry to edit it, which is an often-used shortcut. For instance, double click any rule on firewall_rules.php. Or any entry on firewall_nat.php. Among a variety of others. Every page with multiple items in a list like that.

History

#1 Updated by Steve Beaver almost 4 years ago

  • Status changed from Confirmed to Not a Bug
  • Assignee set to Steve Beaver

All double-click actions have been removed. When I questioned this I was told "It is not a requirement and until someone makes it a requirement, it is gone." (Paraphrasing)

It could be added back in to all the pages that previously had this option, but it would be time-consuming at this point.

Don't shoot the messenger!

#2 Updated by Chris Buechler almost 4 years ago

I later noticed at least some pages still have it. Many don't. Double click to edit is a significant usability benefit that's pretty widely used. Its lacking is annoying the hell out of me, as it will many others. Deserves more consideration. May be something a community effort could get implemented if there's interest.

#3 Updated by Steve Beaver almost 4 years ago

  • Priority changed from Normal to Low

No problem. I can add that back in without too much effort. I'm going to drop it to a lower priority though just because I want to fix all of the brokenness first.

#4 Updated by Steve Beaver over 3 years ago

  • Status changed from Not a Bug to Resolved
  • Target version set to 2.3
  • Affected Version set to 2.3

Double-click action has been restored where it was previously employed.

Let me know if I missed any.

Also available in: Atom PDF