Project

General

Profile

Bug #4982

9 files fail PHP lint

Added by Chris Buechler almost 4 years ago. Updated over 3 years ago.

Status:
Resolved
Priority:
High
Target version:
-
Start date:
08/18/2015
Due date:
% Done:

0%

Estimated time:
Spent time:

Description

some of these covered elsewhere already

:~/gitroot/sbeaver-pfsense$ find . -name '*.php' -exec php -l {} \;|grep -v "No syntax errors" 
PHP Parse error:  syntax error, unexpected end of file in ./usr/local/www/status_dhcpv6_leases.php on line 595
PHP Parse error:  syntax error, unexpected end of file in ./usr/local/www/system_usermanager_addprivs.php on line 211
PHP Parse error:  syntax error, unexpected end of file in ./usr/local/www/system_routes.php on line 303
PHP Parse error:  syntax error, unexpected end of file in ./usr/local/www/system_certmanager.php on line 995
PHP Parse error:  syntax error, unexpected end of file in ./usr/local/www/exec.php on line 275
PHP Parse error:  syntax error, unexpected 'A' (T_STRING), expecting ']' in ./usr/local/www/firewall_nat_edit.php on line 692
PHP Parse error:  syntax error, unexpected '}' in ./usr/local/www/diag_dns.php on line 275
PHP Parse error:  syntax error, unexpected end of file in ./usr/local/www/system_camanager.php on line 605
PHP Parse error:  syntax error, unexpected end of file in ./usr/local/www/system_gateways.php on line 307
PHP Parse error:  syntax error, unexpected end of file in ./usr/local/www/widgets/widgets/ntp_status.widget.php on line 495
PHP Parse error:  syntax error, unexpected 'endforeach' (T_ENDFOREACH) in ./usr/local/www/widgets/widgets/smart_status.widget.php on line 77
PHP Parse error:  syntax error, unexpected end of file in ./usr/local/www/services_unbound_acls.php on line 342
PHP Parse error:  syntax error, unexpected '}' in ./usr/local/www/system_usermanager_passwordmg.php on line 95
PHP Parse error:  syntax error, unexpected end of file in ./usr/local/www/status_dhcp_leases.php on line 447

History

#1 Updated by Steve Beaver almost 4 years ago

  • Assignee set to Steve Beaver

#2 Updated by Steve Beaver almost 4 years ago

  • Status changed from Confirmed to Feedback
  • Assignee changed from Steve Beaver to Chris Buechler

All PHP Lint errors rectified.

All were merge problem dropping braces or replacing ':' with '{'

php -l now produces zero errors on .php and .inc files

#3 Updated by Chris Buechler over 3 years ago

  • Subject changed from 14 files fail PHP lint to 9 files fail PHP lint
  • Status changed from Feedback to Confirmed
  • Assignee changed from Chris Buechler to Steve Beaver

Still 9 more.

PHP Parse error:  syntax error, unexpected end of file in ./usr/local/www/status_dhcpv6_leases.php on line 595
PHP Parse error:  syntax error, unexpected end of file in ./usr/local/www/system_routes.php on line 303
PHP Parse error:  syntax error, unexpected end of file in ./usr/local/www/system_certmanager.php on line 992
PHP Parse error:  syntax error, unexpected end of file in ./usr/local/www/exec.php on line 302
PHP Parse error:  syntax error, unexpected '*' in ./usr/local/www/diag_smart.php on line 57
PHP Parse error:  syntax error, unexpected '}' in ./usr/local/www/diag_dns.php on line 300
PHP Parse error:  syntax error, unexpected end of file in ./usr/local/www/system_camanager.php on line 605
PHP Parse error:  syntax error, unexpected end of file in ./usr/local/www/system_gateways.php on line 307
PHP Parse error:  syntax error, unexpected end of file in ./usr/local/www/status_dhcp_leases.php on line 447

#4 Updated by Steve Beaver over 3 years ago

  • Status changed from Confirmed to Feedback
  • Assignee changed from Steve Beaver to Chris Buechler

Unable to reproduce these 9 errors. Checked my local source, and pulled down the code on my fork to check with the same results. I see zero PHP errors :(

#5 Updated by Chris Buechler over 3 years ago

  • Status changed from Feedback to Resolved

the most recent PHP in Ubuntu is buggy in some regard with lint, checks out fine on PHP 5.5.27.

Also available in: Atom PDF