Project

General

Profile

Actions

Bug #4994

closed

lighttpd broken on latest 2.2.5 snapshot

Added by Kill Bill over 6 years ago. Updated over 6 years ago.

Status:
Not a Bug
Priority:
High
Assignee:
-
Category:
-
Target version:
Start date:
08/24/2015
Due date:
% Done:

0%

Estimated time:
Plus Target Version:
Release Notes:
Affected Version:
Affected Architecture:
amd64

Description

dlopen() failed for: /usr/local/lib/lighttpd/mod_indexfile.so /usr/local/lib/lighttpd/mod_indexfile.so: Undefined symbol "buffer_copy_buffer" 
Actions #1

Updated by Kill Bill over 6 years ago

This is the config file used:

#
#pfBlockerNG Lighttpd DNSBL configuration file
#
server.bind                     = "0.0.0.0" 
server.port                     = "8081" 
server.event-handler            = "freebsd-kqueue" 
server.network-backend          = "writev" 
#server.use-ipv6                = "enable" 
server.dir-listing              = "disable" 
server.errorlog-use-syslog      = "enable" 
server.document-root            = "/usr/local/www/pfblockerng/www/" 
server.pid-file                 = "/var/run/dnsbl.pid" 
server.modules                  = ( "mod_access", "mod_fastcgi", "mod_rewrite" )

server.indexfiles               = ( "index.php" )
mimetype.assign                 = ( ".html" => "text/html", ".txt" => "text/plain", ".jpg" => "image/jpeg", ".png" => "image/png" )
url.access-deny                 = ( "~", ".inc" )
fastcgi.server                  = ( ".php" => ( "localhost" => ( "socket" => "/var/run/php-fpm.socket", "broken-scriptfilename" => "enable" ) ) )

$HTTP["host"] =~ ".*" {
        url.rewrite-once = ( ".*" => "index.php" )
}

$SERVER["socket"] == "0.0.0.0:8443" {
        ssl.engine              = "enable" 
        ssl.pemfile             = "/usr/pbi/pfblockerng-amd64/etc/dnsbl_cert.pem" 
        server.document-root    = "/usr/local/www/pfblockerng/www/" 
        ssl.use-sslv2           = "disable" 
        ssl.use-sslv3           = "disable" 
        ssl.cipher-list         = "AES128+EECDH:AES256+EECDH:AES128+EDH:AES256+EDH:AES128-SHA:AES256-SHA:!aNULL:!eNULL:!DSS" 

        $HTTP["host"] =~ ".*" {
                url.rewrite = ( ".*" => "index.php" )
        }
}

Actions #2

Updated by Kill Bill over 6 years ago

Uhm... please disregard. Traced to broken usage of link() instead of symlink() in package, producing an outdated copy of lighttpd binary.

Actions #3

Updated by Renato Botelho over 6 years ago

  • Status changed from New to Not a Bug
Actions

Also available in: Atom PDF