Project

General

Profile

Bug #5021

can't not select queue/ackqueue on firewall_rules_edit.php where queues exist

Added by Chris Buechler almost 2 years ago. Updated almost 2 years ago.

Status:
Resolved
Priority:
High
Target version:
Start date:
08/26/2015
Due date:
% Done:

100%

Spent time:
Affected version:
2.3
Affected Architecture:

Description

When you have traffic shaper queues configured, and edit a firewall rule, it sets the queue to the first in the list and doesn't allow you to not select a queue.

Associated revisions

Revision 23eeaadf
Added by Steve Beaver almost 2 years ago

Fixed #5021
Selector value creation revised

History

#1 Updated by Chris Buechler almost 2 years ago

  • Priority changed from Normal to High

this one really problematic on anything with queues defined. example: https://bootstrap-test1.pfmechanics.com

#2 Updated by Steve Beaver almost 2 years ago

  • Status changed from Confirmed to Feedback
  • Assignee changed from Steve Beaver to Chris Buechler

Would you mind setting this one up again please? This: https://bootstrap-test1.pfmechanics.com no longer reachable.

#3 Updated by Chris Buechler almost 2 years ago

  • Status changed from Feedback to Confirmed
  • Assignee changed from Chris Buechler to Steve Beaver

that system's stable again and still has an example case.

#4 Updated by Steve Beaver almost 2 years ago

  • Status changed from Confirmed to Feedback
  • Assignee changed from Steve Beaver to Chris Buechler

Added 'None' option and changed initial value to accommodate new rule

#5 Updated by Steve Beaver almost 2 years ago

  • % Done changed from 0 to 100

#6 Updated by Chris Buechler almost 2 years ago

  • Status changed from Feedback to Confirmed
  • Assignee changed from Chris Buechler to Steve Beaver

none option exists now. But it doesn't save as such when you select that option, and it doesn't default to that for new rules.

#7 Updated by Steve Beaver almost 2 years ago

  • Status changed from Confirmed to Feedback
  • Assignee changed from Steve Beaver to Chris Buechler

This control is unusual in that it saves two double-quotes to indicate the default value, rather than an empty string as most other pages do.

I have made an appropriate edit, but have not tested it since https://bootstrap-test1.pfmechanics.com is currently broken.

If this fix is not effective, would you please fix the test instance so I can investigate?

#8 Updated by Chris Buechler almost 2 years ago

  • Status changed from Feedback to Confirmed
  • Assignee changed from Chris Buechler to Steve Beaver
  • Target version set to 2.3
  • Affected version set to 2.3

no change.

Access issue because of DNS rebinding not being excluded for domain on Steve's end, discussed elsewhere and he's in now.

#9 Updated by Steve Beaver almost 2 years ago

  • Status changed from Confirmed to Feedback
  • Assignee changed from Steve Beaver to Chris Buechler

Thanks for all the testing help.

Selector values were rived and queues now save correctly.

#11 Updated by Chris Buechler almost 2 years ago

  • Status changed from Feedback to Resolved

fixed

Also available in: Atom PDF