Project

General

Profile

Bug #5069

system_authservers.php - "Type" value cleared on save

Added by Jim Pingle about 4 years ago. Updated about 4 years ago.

Status:
Closed
Priority:
Normal
Assignee:
Target version:
Start date:
09/01/2015
Due date:
% Done:

0%

Estimated time:

Description

  • Create a RADIUS server entry
  • Save
  • Edit the RADIUS server entry -- Name and Type are disabled since they cannot be changed
  • Make a change such as altering the hostname/IP address
  • Save
  • Edit the RADIUS server entry again -- The altered values did not save and the server now shows LDAP.

Running a diff from the config history shows the "type" value is empty after saving.

Quick demo:

History

#1 Updated by Jim Pingle about 4 years ago

Same thing happens to the Descriptive Name field with LDAP... Save and the name and type both go blank. Probably since the form fields are disabled.

IIRC in cases like this in the past some code would re-enable disabled fields when clicking save before POST so the fields would still be submitted.

#2 Updated by Steve Beaver about 4 years ago

  • Status changed from Confirmed to Feedback
  • Assignee changed from Steve Beaver to Jim Pingle

Inputs should be readonly, not disabled when not required. Disabling prevents them from being submitted and breaks the form.

#3 Updated by Jim Pingle about 4 years ago

  • Status changed from Feedback to Assigned
  • Assignee changed from Jim Pingle to Steve Beaver

The save behavior is OK but there is a weird display issue with the "Type" drop-down, it still renders as a drop-down but with the other choice disabled. So it's good in that you can't change it, but it still appears as though it's enabled and able to be changed.

Current behavior is fine, if the look can't be changed this can just be closed.

#4 Updated by Steve Beaver about 4 years ago

  • Status changed from Assigned to Closed
  • Assignee changed from Steve Beaver to Jim Pingle

This is a bootstrap oddity. "<select>"s don't support the readonly attribute so you have to disable them. Disabling prevents them being submitted in the form, however. The solution is to disable the options, but not the select.

There have been many complaints about this and it is expected to be addressed in a future release.

#5 Updated by Jim Pingle about 4 years ago

OK. In the 2.2.x the value was presented as plain text when editing, rather than any sort of entry control. That may be something else to consider if they don't fix it.

Also available in: Atom PDF