Project

General

Profile

Bug #5070

interfaces.php - Attempting to add a new gateway fails in several ways

Added by Jim Pingle over 3 years ago. Updated over 3 years ago.

Status:
Closed
Priority:
Normal
Assignee:
-
Target version:
Start date:
09/01/2015
Due date:
% Done:

0%

Estimated time:

Description

When changing an interface to "Static IPv4", there is a button to "Add a New Gateway". On 2.2.x this was all dynamic/JS/AJAX style. Click the link, a form appeared, fill in the form, save and it added the entry to the gateways list/drop-down (and config.xml) without reloading the page.

On 2.3 clicking the "Add a New Gateway" button appears to submit the whole page which results in an input validation error.

The following input errors were detected:

A valid gateway must be specified.

Filling in the gateway form and then clicking "Add" also fails with the same error.

History

#1 Updated by Steve Beaver over 3 years ago

  • Status changed from Confirmed to Closed
  • Assignee deleted (Steve Beaver)

This issue is being closed because the interfaces.php page had not been converted at the time of opening and no javascript actions were present. It will be retested once the page is finished.

Also available in: Atom PDF