Project

General

Profile

Bug #5088

system_authservers.php - When input validation errors occur, several field values are lost

Added by Jim Pingle over 3 years ago. Updated over 3 years ago.

Status:
Resolved
Priority:
Normal
Assignee:
Target version:
Start date:
09/03/2015
Due date:
% Done:

100%

Estimated time:
Spent time:

Description

When you save an auth server, LDAP for example, and an input validation problem happens, several fields are lost. Might be more than this but this is what I noticed:

  • Authentication containers is blank
  • User/group/member attributes reset

Associated revisions

Revision 7b4b0ad3 (diff)
Added by Steve Beaver over 3 years ago

Fixed #5088
Functionality was not present in 2.2. Added $pconfig = $_POST to restore form contents on validation failure

Revision 504bd882 (diff)
Added by Steve Beaver over 3 years ago

Fixed #5088
Form restoration revisited

History

#1 Updated by Steve Beaver over 3 years ago

  • Status changed from Confirmed to Feedback
  • Assignee changed from Steve Beaver to Jim Pingle

Functionality was not present in 2.2. Added $pconfig = $_POST to restore form contents on validation failure

#2 Updated by Steve Beaver over 3 years ago

  • % Done changed from 0 to 100

#3 Updated by Jim Pingle over 3 years ago

  • Status changed from Feedback to Confirmed
  • Assignee changed from Jim Pingle to Steve Beaver

Behavior seems to be the same. Some fields like "Base DN" stay, but the ones mentioned in the original description disappear (e.g. Authentication Containers)

For testing, here are the fields and what I entered. To reproduce the input error, simply make a second entry with an identical name:

Descriptive Name: OpenLDAPTest
Type: LDAP
Hostname or IP address: 192.168.1.2
Port value: 389
Transport: TCP - Standard
Protocol Version: 3
Search Scope:
Level: Entire Subtree
Base DN: dc=pfsense,dc=org
Authentication Containers: ou=people,dc=pfsense,dc=org;ou=groups,dc=pfsense,dc=org
Extended Query: Checked, memberOf=cn=foo (not really valid but doesn't need to be)
Bind anonymous: Checked
Initial Template: OpenLDAP
User naming attribute: cn
Group naming attribute: cn
Group member attribute: memberUid
UTF8: Checked
Username Alterations: Unchecked

#4 Updated by Steve Beaver over 3 years ago

  • Status changed from Confirmed to Feedback

#5 Updated by Steve Beaver over 3 years ago

  • Assignee changed from Steve Beaver to Jim Pingle

I had been testing by omitting the IP address and so causing an error. Unfortunately that takes a slightly different code path than the duplicate entry error.

Now corrected.

#6 Updated by Jim Pingle over 3 years ago

  • Status changed from Feedback to Resolved

Works correctly now, thanks!

Also available in: Atom PDF