Project

General

Profile

Bug #5098

system_certmanager.php - SAN Selection drop-down is not using proper values

Added by Jim Pingle almost 4 years ago. Updated almost 4 years ago.

Status:
Resolved
Priority:
Normal
Assignee:
Target version:
Start date:
09/03/2015
Due date:
% Done:

0%

Estimated time:

Description

The SAN choices when creating a certificate need to use proper backend values to pass validation and work properly:

"FQDN or Hostname" should store a value of "DNS"
"IP address" should store a value of "IP"
"URI" should store a value of "URI"
"email address" should store a value of "email"

Associated revisions

Revision 3f0efd58 (diff)
Added by Steve Beaver almost 4 years ago

Fixed #5098
Page re-written to use jQuery row add/delete

History

#1 Updated by Steve Beaver almost 4 years ago

  • Status changed from Confirmed to Assigned

The correct select values are used, but they are not being stored properly because the programmer used the enableDuplication() method, which changes the data format to an array, but did not change the $_POST PHP to match.

#5097 has the same cause.

I'll remove that method and use jQuery instead.

#2 Updated by Steve Beaver almost 4 years ago

  • Status changed from Assigned to Feedback
  • Assignee changed from Steve Beaver to Jim Pingle

Page re-write to use jQuery for row add/delete

#3 Updated by Steve Beaver almost 4 years ago

  • % Done changed from 0 to 100

#4 Updated by Jim Pingle almost 4 years ago

  • Status changed from Feedback to Resolved
  • % Done changed from 100 to 0

Works fine now, thanks!

Also available in: Atom PDF