Project

General

Profile

Bug #5136

Network interface IP address set to alias after reboot

Added by Guillaume Hilt almost 4 years ago. Updated almost 4 years ago.

Status:
Duplicate
Priority:
High
Assignee:
-
Category:
Interfaces
Target version:
-
Start date:
09/15/2015
Due date:
% Done:

0%

Estimated time:
Affected Version:
Affected Architecture:

Description

Using pfSense 2.2.4 on an APU board, I have a bridged LAN_WLAN interface on 192.168.1.1/24 with 2 IP Alias : 192.168.2.1/24 & 192.168.3.1/24.

When rebooting, 192.168.2.1 becomes the LAN_WLAN interface primary address :
- computers can't ping pfsense gateway or access internet
- computers can access pfsense web interface
- pfsense can ping network computer and access internet
- DHCP relay on LAN interface doesn't work anymore

192.168.2.1 is displayed as IP address for LAN_WLAN interface on the dashboard.

How to fix :
- click "Save" on "Interfaces > LAN_WLAN" (IPv4 address is still displayed as 192.168.1.1) without changing anything
- click "Save" on "Services > DHCP Relay" without changing anything

My interfaces :
- WAN1 (DHCP/DHCP6) : re1
- WAN2 (DHCP/DHCP6) : re2
- LAN_WLAN (192.168.1.1/none) : BRIDGE0 (OPT1+WLAN)
- WLAN (none/none) : ath0
- LAN (none/none) : re0

I'm unable to reproduce this bug on pfSense 2.2.2.

History

#1 Updated by Chris Buechler almost 4 years ago

  • Status changed from New to Duplicate
  • Affected Version deleted (2.2.4)

this has always been an issue. root cause in #3997

Also available in: Atom PDF