Project

General

Profile

Actions

Bug #5346

closed

2.2.4 WLAN on WAN causes Kernel Crash

Added by Ramon Buckland almost 6 years ago. Updated almost 6 years ago.

Status:
Duplicate
Priority:
Normal
Assignee:
-
Category:
Operating System
Target version:
-
Start date:
10/26/2015
Due date:
% Done:

0%

Estimated time:
Plus Target Version:
Release Notes:
Affected Version:
Affected Architecture:
i386

Description

Setup:
- 4G WiFi modem / 802.11g/n Channel 2 / WPA2 Personal / AES Encryption

pfsense: 2.2.4

Dell Lattitude D630
WAN: Intel(R) Wireless WiFi Link 4965
LAN: Broadcom Gigabit Ethernet Controller

Background:
this laptop has been running my home firewall for over 4 years on 2.1.x (up to 2.1.3)
The setup has varied at times (different houses).

This recent house move, I have been using it with a WiFi 4G modem. the pfsense WAN link is Wifi with the Access point and Password set in the WAN config.
It works well.

The attempted upgrade (wanted a working squid proxy) to 2.2.4 came with a consistent kernel crash.

What I have observed:

on 2.1.5:

The WAN WiFI link is - AES, 802.11g, WPA2 Personal, Channel 2 between pfsense and the 4G Wifi modem.

on 2.2.4:

The WAN Wifi link "attempted" was 802.11n, AES, WPA2 Personal : Crashes Kernel as soon as the link attempts to DHCP.
The premises I am in, has a "public" subscription WiFi. When pfsense is first setup, the WAN link connects to this public WiFi link, as their is no encrypted password, it works. (Tomizone@BellaVista)
When I change the SSID to mine, ("traady-9 - see attached") with WPA2 encryption, the kernel crashes and the machine reboots.

on 2.1.5:

The WAN WiFi link works on either TomiZone (public, no encryption) or mine, (AES, WPA2)

Attached are some debug details of the two wifi access points described above.

As I have to work (use the internet), I have not gone back to testing 2.2.4 to assess what the cause is.
If someone wants to provide some steps for extra info they may require I am happy to do the leg work and work out what the cause is.

---- extra info ----

The same crash occured with a Lenovo X420, same setup - WAN wifi to "traady-9" interface.


Files

Screen Shot 2015-10-27 at 11.50.35.png (112 KB) Screen Shot 2015-10-27 at 11.50.35.png Tomizone WiFi Link Ramon Buckland, 10/26/2015 07:52 PM
Screen Shot 2015-10-27 at 11.51.06.png (111 KB) Screen Shot 2015-10-27 at 11.51.06.png traady-9 WiFi Link Ramon Buckland, 10/26/2015 07:52 PM
Actions #1

Updated by Chris Buechler almost 6 years ago

  • Project changed from pfSense Packages to pfSense
  • Category set to Operating System
  • Status changed from New to Duplicate
  • Target version deleted (2.2.5)
  • Affected Version deleted (2.2.4)

duplicate of #4740. The sleep there might work around the issue, if you could try that and report back on #4740 it'd be appreciated.

Actions #2

Updated by Ramon Buckland almost 6 years ago

This bug can be closed. The resolution is indeed found in #4740

Actions

Also available in: Atom PDF