Project

General

Profile

Bug #5365

diag_logs_filter_dynamic.php not so dynamic

Added by Steve Beaver over 3 years ago. Updated over 3 years ago.

Status:
Resolved
Priority:
Normal
Assignee:
Target version:
Start date:
11/02/2015
Due date:
% Done:

0%

Estimated time:

Description

There is no "dynamic" to Firewall Log Dynamic view.
diag_logs_filter_dynamic.php refers to /javascript/filter_log.js

But master branch no longer has a "javascript" folder. I can't see filter_log.js anywhere in master. This seems to remove any hope of the various bits of PHP and JavaScript working together to provide dynamic updates.

This makes it hard to test other stuff about the dynamic view and dynamically updated rows, because I can't get any dynamic update to happen at all.
Modify message

History

#1 Updated by Steve Beaver over 3 years ago

  • Status changed from Confirmed to Feedback

Dynamism has been restored.

etc/inc/filter_log.inc has been updated to use fa icon, but still needs work similar to PR 2016 (?)

#2 Updated by Phillip Davis over 3 years ago

https://github.com/pfsense/pfsense/pull/2019
should help with the cross/tick button and getting the syntax correct for the popup rule display.

#3 Updated by Steve Beaver over 3 years ago

  • Status changed from Feedback to Resolved

Also available in: Atom PDF