Project

General

Profile

Bug #5381

syntax error, unexpected ';' in /usr/local/www/wizard.php(156) : eval()'d code on line 3

Added by Chris Buechler over 3 years ago. Updated over 3 years ago.

Status:
Resolved
Priority:
Normal
Target version:
Start date:
11/07/2015
Due date:
% Done:

100%

Estimated time:

Description

Go through the setup wizard, set the hostname and timezone, leave rest at defaults. Go back to the dashboard at the end and you'll have a crash report.

PHP Errors:
[07-Nov-2015 06:53:46 Etc/UTC] PHP Parse error:  syntax error, unexpected ';' in /usr/local/www/wizard.php(156) : eval()'d code on line 3
[07-Nov-2015 06:53:46 Etc/UTC] PHP Stack trace:
[07-Nov-2015 06:53:46 Etc/UTC] PHP   1. {main}() /usr/local/www/wizard.php:0

Associated revisions

History

#1 Updated by Steve Beaver over 3 years ago

  • Status changed from Confirmed to Feedback
  • Assignee set to Chris Buechler

I'm guessing this is the culprit: (line 3 of the PHP)


    <stepsubmitphpaction>
    if($_POST['adminpassword'] != "") {
        if($_POST['adminpassword'] == $_POST['adminpasswordagain']) {
            $admin_user =&amp; getUserEntryByUID(0);
            local_user_set_password($admin_user, $_POST['adminpassword']);
            local_user_set($admin_user);
            write_config();
        } else {
            print_info_box_np("Passwords do not match!  Please press back in your browser window and correct.");
            die;
        }
    }
    </stepsubmitphpaction>

Its the same in 2.2.4 though. Was it always that way?

#2 Updated by Kill Bill over 3 years ago

Put that between CDATA.

#3 Updated by Kill Bill over 3 years ago

And in general, all that entity crap in that file (like descriptions) would benefit from the same. Completely unreadable.

#4 Updated by Steve Beaver over 3 years ago

Sure, but it's interesting that this problem has been in there since RELENG_2.0

#5 Updated by Steve Beaver over 3 years ago

php corrected and wrapped in <![CDATA[ ]]>

#6 Updated by Steve Beaver over 3 years ago

  • % Done changed from 0 to 100

#7 Updated by Chris Buechler over 3 years ago

  • Status changed from Feedback to Resolved
  • Affected Version changed from 2.3 to All

Not sure how that never generated a crash report before. Works, thanks!

#8 Updated by Chris Buechler over 3 years ago

  • Affected Version changed from All to 2.3

Also available in: Atom PDF