Project

General

Profile

Bug #5419

firewall_rules.php - Drag and drop of floating rules erases all rules on other interfaces

Added by Jim Pingle over 3 years ago. Updated over 3 years ago.

Status:
Resolved
Priority:
Very High
Assignee:
Target version:
Start date:
11/11/2015
Due date:
% Done:

0%

Estimated time:

Description

Drag and drop to reorder rules on the Floating tab of firewall_rules.php will blow away rules for all other interfaces. Only thing left is floating rules.

History

#1 Updated by Jim Pingle over 3 years ago

  • Subject changed from firewall_rules.php - Drag and drop of floating rules erases all rules on other interfaces to firewall_rules.php - Drag and drop of rules erases all rules on other interfaces
  • Description updated (diff)

Updating the title/descr to reflect that it happens on any interface.

#2 Updated by Steve Beaver over 3 years ago

  • Subject changed from firewall_rules.php - Drag and drop of rules erases all rules on other interfaces to firewall_rules.php - Drag and drop of floating rules erases all rules on other interfaces
  • Description updated (diff)
  • Status changed from Confirmed to Feedback
  • Assignee changed from Steve Beaver to Jim Pingle

Fixed by changing rule filter method.

#3 Updated by Jim Pingle over 3 years ago

  • Status changed from Feedback to Assigned
  • Assignee changed from Jim Pingle to Steve Beaver

It doesn't erase other rules now but it also appears to have no effect. Clicking Save reverts the rules to their order before dragging

#4 Updated by Steve Beaver over 3 years ago

  • Status changed from Assigned to Feedback
  • Assignee changed from Steve Beaver to Jim Pingle

Removed debugging and tested.

#5 Updated by Jim Pingle over 3 years ago

  • Status changed from Feedback to Resolved

Seems to work now. Saves the intended order and doesn't remove other rules.

Also available in: Atom PDF