Project

General

Profile

Bug #548

Inconsistent DHCP behavior when renumbering LAN

Added by Jim Pingle about 9 years ago. Updated about 9 years ago.

Status:
Resolved
Priority:
Normal
Assignee:
-
Category:
DHCP Server
Target version:
Start date:
04/26/2010
Due date:
% Done:

0%

Estimated time:
Affected Version:
2.0
Affected Architecture:

Description

When you change the LAN IP in the GUI, the note says to change the DHCP settings before applying. However, when you try to actually change the DHCP settings to match, it fails saying "The specified range lies outside of the current subnet".

Associated revisions

Revision 2b001b5d (diff)
Added by Ermal Luçi about 9 years ago

Ticket #548. Change message displayed when modifying an interface to actually tell people to modify dhcp server setting after applying settings since the interface configuration/ip will only change after applying settings and pfSense does not read the interface address from the config but from the interface itself and the complications for this and possibly other cases are not worth the effort.

History

#1 Updated by Jim Pingle about 9 years ago

Actually it appears as though this may be due to the fact that when you change the LAN IP, it doesn't actually update the IP address. I didn't notice the first time that the old IP is still present in the page, even after resubmitting the new value again. Applying changes also somehow results in no IP address on the LAN interface.

#2 Updated by Jim Pingle about 9 years ago

  • Status changed from New to Closed

This has nothing to do with DHCP. I'm trying to track down/reproduce the real cause of the problem (changing the LAN IP doesn't always take)

#3 Updated by Jim Pingle about 9 years ago

  • Status changed from Closed to New

And apparently I'm much too quick on the trigger today. The DHCP settings are a problem even when the LAN IP does change properly.

#4 Updated by Daniel Lloyd about 9 years ago

Looks to be related to Bug #459, where ip2long returns an unsigned int on 64 bit.

#5 Updated by Jim Pingle about 9 years ago

No, I am seeing this on 32-bit. And it is not an IP calculation issue, the DHCP page retains the old subnet when it should be displaying the new.

#6 Updated by Daniel Lloyd about 9 years ago

I apologize, I am seeing this exact error message on a new install without having changed the LAN subnet and noticed that on line 148 'ip2long($_POST['ipaddr']) > $lansubnet_end)) { ' $lansubnet_end is negative. This must be unrelated to the issue in this bug, sorry for the noise.

#7 Updated by Ermal Luçi about 9 years ago

  • Status changed from New to Feedback

#8 Updated by Jim Pingle about 9 years ago

  • Status changed from Feedback to Resolved

Looks like a good fix to me, and going this route, we don't imply that the user has to open a new window/tab or navigate back like the previous message did.

Also available in: Atom PDF