Project

General

Profile

Bug #5519

interfaces.widget.php - Two status icons showing

Added by Jim Pingle over 3 years ago. Updated over 3 years ago.

Status:
Resolved
Priority:
Normal
Assignee:
Category:
Dashboard
Target version:
Start date:
11/23/2015
Due date:
% Done:

100%

Estimated time:
Affected Version:
2.3
Affected Architecture:
All

Description

On the interfaces widget there are two status icons shown for an interface when there should only be one.

The first icon used to be (on 2.2.x) an indication of the type of interface, not the status. The second icon is for status and seems to be OK/proper.

Looks to be due to the re-use of $icon in the widget.

I've got a fix, will push momentarily

Associated revisions

Revision 0520c675 (diff)
Added by Jim Pingle over 3 years ago

Don't reuse $icon here - results should be two different icons. Fixes #5519

History

#1 Updated by Jim Pingle over 3 years ago

  • Status changed from Confirmed to Feedback
  • % Done changed from 0 to 100

#2 Updated by Jim Pingle over 3 years ago

  • Status changed from Feedback to Resolved

Looks good now, also fixed up the interface type icons while I was there.

Also available in: Atom PDF