Project

General

Profile

Actions

Bug #5638

closed

services_unbound_host_edit.php clicking Add Host Name blanks out all input fields

Added by Phillip Davis almost 6 years ago. Updated almost 6 years ago.

Status:
Resolved
Priority:
Normal
Assignee:
Category:
DNS Resolver
Target version:
Start date:
12/14/2015
Due date:
% Done:

100%

Estimated time:
Plus Target Version:
Release Notes:
Affected Version:
2.3
Affected Architecture:

Description

DNS Resolver, add a host override
Enter stuff in the normal Host, Domain, IP Address, Description fields.
Click Add Host Name in the "Additional names for this host" section"
The stuff you entered in the top 4 fields is blanked out!!!

You can make an entry by first clicking "Add Host Name" enough times to make the number of rows you need, then enter all the data and Save.

Same problem if you edit an existing entry and try to "Add Host Name".

Same problem in DNS Forwarder.

Actions #1

Updated by Phillip Davis almost 6 years ago

Actually you can't make a 2nd additional name - when you click "Add Host Name" each time it just comes back with an empty form with just a single row for an additional name.

Actions #2

Updated by Steve Beaver almost 6 years ago

Looks like this was coded in a way that requires the user to save after adding each new host. What it really needs is our jQuery "repeatable" class.

I'll add that now.

Actions #3

Updated by Steve Beaver almost 6 years ago

  • Status changed from New to Confirmed
  • Assignee set to Steve Beaver
Actions #4

Updated by Steve Beaver almost 6 years ago

  • Status changed from Confirmed to Feedback
  • Assignee changed from Steve Beaver to Phillip Davis

Fixed by converting to 'repeatable' class and jQuery

Actions #5

Updated by Steve Beaver almost 6 years ago

  • % Done changed from 0 to 100
Actions #6

Updated by Phillip Davis almost 6 years ago

The same sort of changes will be needed for DNS Forwarder - services dnsmasq...

Actions #8

Updated by Steve Beaver almost 6 years ago

  • Status changed from Feedback to Resolved
Actions

Also available in: Atom PDF