Project

General

Profile

Actions

Bug #5659

closed

Dashboard widgets disappear and are unrecoverable if the column is blank in their configuration

Added by Jim Pingle almost 6 years ago. Updated almost 6 years ago.

Status:
Resolved
Priority:
Normal
Assignee:
Category:
Dashboard
Target version:
Start date:
12/18/2015
Due date:
% Done:

100%

Estimated time:
Plus Target Version:
Release Notes:
Affected Version:
2.3
Affected Architecture:
All

Description

Not sure how the column was blank in the config but at one point blank must have been assumed to be "col1" and that has since changed. If the widget has, for example, system_information::open the system information widget will disappear. If other widgets such as IPsec suffer the same fate, they are also missing from display and the Available Widgets panel. Fixing the specification to be system_information:col1:open will bring it back, likewise for other widgets.

Granted this particular firewall has been through a lot over changes over the years, but when the problem presented the widget config was:

<sequence>system_information::open,services_status::open,openvpn::open,undefined::close,undefined::close,undefined::close,ipsec::open,traffic_graphs::open,gateways:col2:open,interfaces:col2:open,log:col2:open,interface_statistics:col2:open,thermal_sensors:col2:open,smart_status:col2:open,[object Object]:col2:open</sequence>

Cleaning that up a bit it all worked when I changed it to this:

    <sequence>system_information:col1:open,services_status:col1:open,openvpn:col1:open,ipsec:col1:open,traffic_graphs:col1:open,gateways:col2:open,interfaces:col2:open,log:col2:open,interface_statistics:col2:open,thermal_sensors:col2:open,smart_status:col2:open</sequence>

Actions #1

Updated by Steve Beaver almost 6 years ago

Added code to assign a temporary display column if that information is missing from the config.

At one time this was part of the upgrade_config script, but it looks like it was removed.

Actions #2

Updated by Steve Beaver almost 6 years ago

  • Assignee changed from Steve Beaver to Jared Dillard
Actions #3

Updated by Steve Beaver almost 6 years ago

  • Status changed from Confirmed to Feedback
  • Assignee changed from Jared Dillard to Jim Pingle

Tested by deleting column information from <sequence> and rebooting. All widgets display correctly.

Actions #4

Updated by Steve Beaver almost 6 years ago

  • % Done changed from 0 to 100
Actions #5

Updated by Jim Pingle almost 6 years ago

  • Status changed from Feedback to Resolved

Looks good now.

FYI- you can test a lot easier by editing config.xml live either with viconfig, or by editing the file and then running "rm /tmp/config.cache" which forces the GUI to reload the config from disk.

Actions

Also available in: Atom PDF