Project

General

Profile

Bug #5745

services_captiveportal.php - Attempting to save portal page, error page, or logout page contents silently fails

Added by Jim Pingle over 3 years ago. Updated over 3 years ago.

Status:
Resolved
Priority:
High
Assignee:
-
Category:
Captive Portal
Target version:
Start date:
01/08/2016
Due date:
% Done:

0%

Estimated time:
Affected Version:
2.3
Affected Architecture:
All

Description

Attempt to browse for and save an .html file for the "Portal Page Contents", "Auth error page contents", or "Logout page contents" and nothing is stored. The save action happens but the submitted file is not present in config.xml after saving.

Associated revisions

Revision 46af3068 (diff)
Added by Steve Beaver over 3 years ago

Fixed #5745 and a few other items discovered during testing

History

#1 Updated by Steve Beaver over 3 years ago

  • Status changed from Confirmed to Feedback
  • % Done changed from 0 to 100

#2 Updated by Steve Beaver over 3 years ago

  • Assignee changed from Steve Beaver to Jim Pingle
  • % Done changed from 100 to 0

Fixed this issue by add multipart encoding to the form.

While testing I also fixed the display of radius protocol radio buttons and the "view" and "download" buttons which work correctly and open a new tab

#3 Updated by Steve Beaver over 3 years ago

  • Status changed from Feedback to Resolved
  • Assignee deleted (Jim Pingle)

Reported as fixed by OP

#4 Updated by Jim Pingle over 3 years ago

Yep, it definitely works.

Also available in: Atom PDF