Project

General

Profile

Bug #5763

OpenVPN client export extraction failed - Unsupported Method

Added by Francisco Cavalcante over 3 years ago. Updated over 3 years ago.

Status:
Resolved
Priority:
Normal
Assignee:
Category:
-
Target version:
Start date:
01/12/2016
Due date:
% Done:

0%

Estimated time:
Affected Version:
2.3
Affected Architecture:
amd64

Description

The file pfSenselabs-udp-1194-install.exe generated when click any options of the "OpenVPN Clients" session of the screen (/vpn_openvpn_export.php), then when executed in Windows 7/8/10 return the message error: Unsupported Method

In my search I saw that the Coded Rar.so was separated from p7zip project.

In Notes from UPDATING of the https://www.freshports.org/archivers/p7zip/
2014-01-02

Affects: users of archivers/p7zip

Author:

Reason:
The MINIMAL and MODULES options have been removed from archivers/p7zip,
which now unconditionally installs the 7z, 7za and 7zr, as if the MINIMAL
option was previously unset.

The RAR decompression codec, whose source code has a more restrictive
license that forbids its use for creating RAR archives, has been moved to
a separate port, archivers/p7zip-codec-rar.

The new p7zip-codec-rar project: http://www.freshports.org/archivers/p7zip-codec-rar/

error.jpg (11.6 KB) error.jpg Error message Francisco Cavalcante, 01/12/2016 07:14 AM

History

#1 Updated by Jim Pingle over 3 years ago

  • Status changed from New to Confirmed
  • Assignee set to Jim Pingle

Hmm, I'm seeing this now also, but the archive doesn't use rar. It uses 7z format, LZMA2 BCJ method. No rar. That can be confirmed by opening the .exe in 7-zip and looking at the archive info. I'll dig at it.

#2 Updated by Jim Pingle over 3 years ago

  • Project changed from pfSense to pfSense Packages
  • Category deleted (Package System)
  • Status changed from Confirmed to Feedback

Updated the export package to 1.3.6, which now bundled OpenVPN 2.3.10, and I switched to a different SFX module which, at least for me, fixes this problem.

Give it a try once the new version shows up to install/update.

#3 Updated by Francisco Cavalcante over 3 years ago

work fine, it's ok

#4 Updated by Jim Pingle over 3 years ago

  • Status changed from Feedback to Resolved

Works for me too on another box. Closing it out.

Also available in: Atom PDF