Project

General

Profile

Bug #5785

igb could not setup receive structures

Added by Patrick Rachels over 3 years ago. Updated over 3 years ago.

Status:
Not a Bug
Priority:
High
Assignee:
-
Category:
Interfaces
Target version:
-
Start date:
01/19/2016
Due date:
% Done:

0%

Estimated time:
Affected Version:
Affected Architecture:
amd64

Description

I just setup a new appliance and am getting the same error that was posted about 2011 found here...

http://redmine.pfsense.org/issues/1221

The image that was loaded is 2.2.6 x64
After install and reboot, just before the setup of the NICs I receive errors on all interfaces stating "igb#: Could not setup receive structures"

This issue in the previous bug was marked resolved but instead still persists.

The setup is a Supermicro Atom C2758 with a Intel Pro 1000 Quad port PCIE NIC

History

#1 Updated by Chris Buechler over 3 years ago

  • Status changed from New to Not a Bug

Has no relation to that old bug. You need to tune accordingly.
https://doc.pfsense.org/index.php/Tuning_and_Troubleshooting_Network_Cards

#2 Updated by Patrick Rachels over 3 years ago

I've already done that, I still have no network access. The errors seem to have gone away, at least from the console but there is still NO network access with the quad NIC installed.

My loader.conf files looks as such...
autoboot_delay="3"
vm.kmem_size="4335544320"
vm.kmem_size_max="535544320"
hw.usb.no_pf="1"
kern.ipc.nmbclusters="1310720"
hw.igb.num_queues="4"
net.inet.tcp.tso="0"

Also available in: Atom PDF