Project

General

Profile

Bug #5815

"State Killing on Gateway Failure" behavior opposite of what it should be

Added by Chris Buechler over 3 years ago. Updated over 3 years ago.

Status:
Resolved
Priority:
Normal
Category:
Web Interface
Target version:
Start date:
01/25/2016
Due date:
% Done:

0%

Estimated time:
Affected Version:
2.3
Affected Architecture:

Description

The "State killing on gateway failure" option in 2.3 is opposite of intended. The confusing "check to disable" likely lead to that. The config tag "kill_states" being used to disable killing of states is also confusing.

Associated revisions

Revision 3756fd86 (diff)
Added by Chris Buechler over 3 years ago

Fix up config setting for killing states on gateway failure. Enable this option where gw_down_kill_states is set. Flip setting accordingly during config upgrade to not use confusing 'kill_states' tag to not kill states. Ticket #5815

History

#1 Updated by Chris Buechler over 3 years ago

  • Status changed from Confirmed to Feedback

this is much more sane now. All looks to work as it should, leaving for additional testing.

#2 Updated by Chris Buechler over 3 years ago

  • Status changed from Feedback to Resolved

works

Also available in: Atom PDF