Project

General

Profile

Bug #5888

all em(4) bridge members endlessly link cycle after one loses and regains link

Added by Chris Buechler over 3 years ago. Updated over 3 years ago.

Status:
Resolved
Priority:
Normal
Category:
Interfaces
Target version:
Start date:
02/12/2016
Due date:
% Done:

0%

Estimated time:
Affected Version:
2.3
Affected Architecture:

Description

Put em NICs in a bridge, unplug and replug one of them, and all the em bridge member interfaces go into continual link cycling.

I have a test setup in place on a 7541 that replicates. Haven't had time to get into it beyond confirming it happens.

Somewhat similar symptoms to old bug #846, but not the same.

also discussed here. https://forum.pfsense.org/index.php?topic=106554.msg593095

Associated revisions

Revision 9af087de (diff)
Added by Chris Buechler over 3 years ago

Revert this because of issues in Ticket #5888, will fix #4312 differently. Revert "interface_bridge_add_member is inadequate for adding a bridge member that may have not existed at the time of bridge interface's creation. interface_bridge_configure on the interface's bridge ensures all settings (private, etc.) are applied. Ticket #4312"

This reverts commit 617daf5e38cefcad2d2f0ac4308f034131be31b7.

History

#1 Updated by Chris Buechler over 3 years ago

  • Status changed from Confirmed to Feedback

this was fixed reverting the change from #4312, will fix that differently.

#2 Updated by Chris Buechler over 3 years ago

  • Status changed from Feedback to Resolved

works

Also available in: Atom PDF