Project

General

Profile

Actions

Bug #5904

closed

OpenVPN P2P Shared Key Local Port wont accept 0

Added by Angel Torres over 5 years ago. Updated over 5 years ago.

Status:
Resolved
Priority:
Normal
Assignee:
Category:
OpenVPN
Target version:
Start date:
02/17/2016
Due date:
% Done:

100%

Estimated time:
Plus Target Version:
Release Notes:
Affected Version:
2.3
Affected Architecture:
amd64

Description

OpenVPN P2P Shared Key config wont accept 0 for a local port as description states for a random port.

Message states "Value Must be greater than or equal to 1"

Leaving field blank seems to work fine for a random port.

Upgraded from a 2.2.6 config so the 0 in Local Port was working as intended but attempting to edit the config results in error stated above.

Actions #1

Updated by Steve Beaver over 5 years ago

  • Status changed from New to Assigned
  • Assignee set to Steve Beaver

Thanks for the report. This is an easy fix. Watch for it in a few minutes :)

Actions #2

Updated by Steve Beaver over 5 years ago

  • Status changed from Assigned to Feedback
  • Assignee changed from Steve Beaver to Angel Torres

Fix pushed. Please gitsync and test, or wait for the next snapshot.

I corrected the issue on both the OpenVPN server and client pages.

Actions #3

Updated by Steve Beaver over 5 years ago

  • % Done changed from 0 to 100
Actions #4

Updated by Angel Torres over 5 years ago

Gitsynced and all is proper now, thank you for the quick fix.

Actions #5

Updated by Steve Beaver over 5 years ago

  • Status changed from Feedback to Resolved
Actions

Also available in: Atom PDF