Project

General

Profile

Bug #5907

User Group Deleted Even If Say Cancel

Added by NOYB NOYB over 3 years ago. Updated over 3 years ago.

Status:
Resolved
Priority:
Normal
Assignee:
-
Category:
Web Interface
Target version:
Start date:
02/19/2016
Due date:
% Done:

0%

Estimated time:
Affected Version:
2.3
Affected Architecture:

History

#1 Updated by Chris Buechler over 3 years ago

  • Category set to User Manager / Privileges
  • Status changed from New to Feedback

not seeing that in IE, Firefox, or Chrome. Anything more to it than that to replicate?

#2 Updated by Steve Beaver over 3 years ago

I cannot reproduce the issue either.

#3 Updated by NOYB NOYB over 3 years ago

I'll fire things up here in a little while and see if I can still replicate the issue.
There really wasn't much to it. Click the delete (trash can) icon and then click cancel on the are you sure popup dialog prompt. I've seen it every time without fail. Think maybe a page refresh/reload may have been involved. Don't recall for sure on that.

#4 Updated by NOYB NOYB over 3 years ago

The cancel button works in Chrome. Group is not deleted.

The cancel button does not work in IE. After page refresh the group is gone.

IE 11
Windows 8.1 pro

#5 Updated by Chris Buechler over 3 years ago

Doesn't happen on Windows 8.1 and IE 11 here

#6 Updated by NOYB NOYB over 3 years ago

Don't really know what to say... But I'll try...

Happens without fail here. Can reproduce every time at will.
System is pretty basic. I don't run a bunch of junk... addons, games, tool bars, etc. It's pretty vanilla system.
Besides, running in a "pinned" shortcut, so addons are not supposed to run anyway. (happens when not running in "pinned" shortcut too so that's not the issue).
Works fine on 2.2.6

I'm at a loss. What sorts of things would have impact on this?

#7 Updated by NOYB NOYB over 3 years ago

Okay found a works/doesn't work data point. Make sure you are sitting down for this.

Clicking the trashcan with mouse (track pad) works.
Selecting the trashcan with touch or stylus does not work.

Seriously.

#8 Updated by Chris Buechler over 3 years ago

  • Status changed from Feedback to Not a Bug
  • Target version deleted (2.3)
  • Affected Version deleted (2.3)

Weird. Yeah that's not something we're going to be able to fix. :) Maybe it's mis-clicking onto OK instead, that seems the most likely given IE obviously knows how to handle OK and cancel.

#9 Updated by NOYB NOYB over 3 years ago

Disagree that it is not a bug. It works fine in 2.2.6 with touch or stylus.

It's not related to the method used for clicking the cancel button. That works either way as long as the trash can is not selected by touch or stylus. It's the trashcan selection method that causes it not to work.

Probably a pretty good possibility to be css related given it works fine in 2.2.6.

An inadvertent touch of the trashcan and the user group can be kissed good-by. No means of canceling. None recoverable.

Sorry but that is a bug. Whether anything is going to be done about it is your prerogative. But it is a bug nonetheless.

#10 Updated by NOYB NOYB over 3 years ago

It is more widespread that just the group manager. It appears to be system wide. Just verified same behavior on firewall rules. So it is something to do with how the delete is being handled. Maybe jquery is involved.

#11 Updated by Chris Buechler over 3 years ago

We have no Windows devices with touch or stylus to try. IE's a small portion of the user base, and touch/stylus is a tiny fraction of that. Pull requests welcome, I'll gladly open it back up if someone finds and submits a fix. We can't fix something we can't replicate, and I don't think we care enough to buy a Windows touchscreen device.

#13 Updated by Steve Beaver over 3 years ago

  • Category changed from User Manager / Privileges to Web Interface
  • Status changed from Not a Bug to Resolved
  • Target version set to 2.3
  • Affected Version set to 2.3

PR 2685 tested and merged. Thank you!

#14 Updated by Chris Buechler over 3 years ago

thanks NYOB.

Also available in: Atom PDF