Project

General

Profile

Bug #5977

system_advanced_admin.php - foreach error when no certs are present on the system

Added by Jim Pingle over 3 years ago. Updated over 3 years ago.

Status:
Resolved
Priority:
Normal
Assignee:
Category:
Web Interface
Target version:
Start date:
03/11/2016
Due date:
% Done:

100%

Estimated time:
Affected Version:
2.3
Affected Architecture:

Description

When the config contains no certs (http mode, all certs deleted), a foreach error is shown on System > Advanced, Admin Access tab:

Warning: Invalid argument supplied for foreach() in /usr/local/www/system_advanced_admin.php on line 365 Call Stack: 0.0015 230984 1. {main}() /usr/local/www/system_advanced_admin.php:0 

I have a fix, will push momentarily.

Associated revisions

Revision b95e3de4 (diff)
Added by Jim Pingle over 3 years ago

Ensure $a_cert is always an array. Fixes #5977

History

#1 Updated by Jim Pingle over 3 years ago

  • Status changed from Assigned to Feedback
  • % Done changed from 0 to 100

#2 Updated by Jim Pingle over 3 years ago

  • Status changed from Feedback to Resolved

OK now

Also available in: Atom PDF