Project

General

Profile

Bug #6008

Can't create GRE tunnel on IP Alias VIP

Added by Ed Byrne over 4 years ago. Updated over 4 years ago.

Status:
Duplicate
Priority:
Normal
Assignee:
-
Category:
Virtual IP Addresses
Target version:
-
Start date:
03/17/2016
Due date:
% Done:

0%

Estimated time:
Affected Version:
Affected Architecture:

Description

I need to create a tunnel with my local endpoint being a virtual IP. I initially created an IP Alias VIP on loopback, but it givse me an error in system.log when it tries to apply the changes:

Mar 17 11:29:50 pfsense php-fpm70680: /interfaces_gre_edit.php: The command '/sbin/ifconfig gre0 tunnel '10.249.254.1'' returned exit code '1', the output was 'ifconfig: 'tunnel' requires 2 arguments'

It resulted in a GRE interface that looked like:

gre0: flags=9011<UP,POINTOPOINT,LINK0,MULTICAST> metric 0 mtu 1476
inet 10.249.5.78 --> 10.249.5.77 netmask 0xfffffffc
inet6 fe80::225:90ff:fe09:d6bc%gre0 prefixlen 64 scopeid 0xd
nd6 options=21<PERFORMNUD,AUTO_LINKLOCAL>

If I manually run a 'ifconfig gre0 tunnel 10.249.0.85 10.249.254.1', it works and the tunnel interface is created properly, and I am able to ping across it.

gre0: flags=9051<UP,POINTOPOINT,RUNNING,LINK0,MULTICAST> metric 0 mtu 1476
tunnel inet 10.249.0.85 --> 10.249.254.1
inet 10.249.5.78 --> 10.249.5.77 netmask 0xfffffffc
inet6 fe80::225:90ff:fe09:d6bc%gre0 prefixlen 64 scopeid 0xd
nd6 options=21<PERFORMNUD,AUTO_LINKLOCAL>

I tried moving the IP Alias VIP to a physical interface, and I get the same behavior. Using a CARP VIP instead of an IP alias VIP does properly create the gre0 interface, but as manual configuration works, it seems like this is a bug in the web UI. This is on 2.2.6-RELEASE (Community Edition) which doesn't seem to be in the "Affected version' list in redmine.

History

#1 Updated by Chris Buechler over 4 years ago

  • Status changed from New to Duplicate
  • Affected Version deleted (2.2.x)

duplicate of #4450, already fixed in 2.3.

Also available in: Atom PDF