Project

General

Profile

Bug #6015

95th percentile numbers wrong in monitoring graph

Added by Chris Buechler over 3 years ago. Updated over 3 years ago.

Status:
Resolved
Priority:
Normal
Assignee:
Category:
RRD Graphs
Target version:
Start date:
03/19/2016
Due date:
% Done:

0%

Estimated time:
Affected Version:
2.3
Affected Architecture:

Description

status_monitoring.php's 95th percentile numbers are way off for at least inpass and outpass total. For instance, the most recent period on my WAN graph right now (attached) has a 95th percentile of 9 Kbps, while the inpass total (which should be barely more) is 2.94 Mbps 95th. The latter number may be correct, or at least is much closer to correct. The outpass total 95th is lower than the outpass, which is impossible.

Selection_029.png (39.3 KB) Selection_029.png Chris Buechler, 03/19/2016 11:38 PM

History

#1 Updated by Jared Dillard over 3 years ago

  • Status changed from Confirmed to Feedback

It turns out "outblock6" was missing and might have thrown things off. I fixed that issue and it may have fixed the 95th percentile issue (I was unable to find a system that could replicate so far).

#2 Updated by Jared Dillard over 3 years ago

I added a CSV export option so we can double check the numbers if you want to give that a shot.

#3 Updated by Jared Dillard over 3 years ago

It was sorting alphabetically, instead of numerically, before calculating the percentile. It sorts appropriately now and displays the correct percentile.

#4 Updated by Chris Buechler over 3 years ago

this appears to be sane now. I still need to verify some additional data sets.

#5 Updated by Chris Buechler over 3 years ago

  • Status changed from Feedback to Resolved

looks good

Also available in: Atom PDF