Project

General

Profile

Bug #6019

Squid service runs but doesn't process requests after reboot

Added by Orsiris de Jong almost 4 years ago. Updated about 3 years ago.

Status:
Closed
Priority:
Normal
Assignee:
-
Category:
Squid
Target version:
-
Start date:
03/22/2016
Due date:
% Done:

0%

Estimated time:
Affected Version:
Affected Architecture:

Description

Hello,

Strange problem here. I'm running Squid + squidguard in transparent mode.
Everything works find until I reboot, the services launch but when I do a proxy test (eg: http://www.lagado.com/proxy-test ), I don't use squid.
The access log also don't increase.

If I happen to restart squid via ssh (service squid.sh restart), nothing changes.
If I happen to change any setting (like language) in Squid via GUI, everything starts working normally.

Any clues of what I should provide you for diag ?

Regards,
Ozy.

History

#1 Updated by Orsiris de Jong almost 4 years ago

I'm running captive portal too, which works great.
If I happen to disable transparent proxy and reboot pfSense, everything works as expected.

#2 Updated by Orsiris de Jong almost 4 years ago

Should have some sleep, forgot to mention essential:
Running 2.3-BETA (amd64) built on Tue Mar 22 02:17:00 CDT 2016

#3 Updated by Orsiris de Jong almost 4 years ago

I've been runnning various tests about this problem, and have updated to 2.3-BETA built on Tue Mar 29 01:50:40 CDT 2016.

It seems that the problem gets resolved when i uncheck "Bypass Proxy for Private Address Destination".
Could the fact that my WAN lies in a private address space cause this issue ?
Still, the problem doesn't always happen, so it makes it hard to diag...

#4 Updated by Kill Bill about 3 years ago

Duplicate of #5594. Squid won't work with CP.

#5 Updated by Jim Pingle about 3 years ago

  • Status changed from New to Closed

Also available in: Atom PDF