Project

General

Profile

Actions

Bug #6135

closed

All Static ARP DHCP leases showing online in Status -> DHCP Leases

Added by Trel S almost 6 years ago. Updated almost 6 years ago.

Status:
Not a Bug
Priority:
Normal
Assignee:
-
Category:
Web Interface
Target version:
-
Start date:
04/13/2016
Due date:
% Done:

0%

Estimated time:
Plus Target Version:
Release Notes:
Affected Version:
Affected Architecture:

Description

I took at look at DHCP leases, and everything that's a static lease (ARP entry enabled) is listed as online.
This includes 2 Raspberry Pi units that have not been plugged in for multiple months.

I don't see a single instance of "offline" listed for any active lease, regardless of it the device is actually online or not.

(I'm not sure if this is a DHCP thing or simply a UI thing)

Actions #1

Updated by Chris Buechler almost 6 years ago

  • Status changed from New to Not a Bug
  • Affected Version deleted (2.3)

The system checks the ARP table to see what's live. Hosts with static ARP will always be "live" in that case. There is no good way to do online checks in that case.

Actions #2

Updated by Chris Buechler almost 6 years ago

  • Subject changed from All Static DHCP leases showing online in Status -> DHCP Leases to All Static ARP DHCP leases showing online in Status -> DHCP Leases
Actions

Also available in: Atom PDF