Project

General

Profile

Bug #6363

AutoConfigBackup Restore Actions column missing due to long XMLRPC sync merge strings in the configuration description

Added by Brett Merrick over 1 year ago. Updated about 1 month ago.

Status:
Resolved
Priority:
Normal
Assignee:
Category:
Backup/restore
Target version:
Start date:
05/17/2016
Due date:
% Done:

0%

Affected Version:
All
Affected Architecture:
All

Description

On a backup firewall in an HA cluster, when the backup has been triggered by a merged-in config the "Configuration Change" text can be very long.

On Google Chrome this forces the "Actions" column to be invisible.

The following css resolves the issue, although I'm not sure if it belongs in the core or the package:

table#backups {
table-layout: fixed;
word-wrap: break-word;
}

Screen Shot 2017-08-28 at 10.48.23 AM.png (145 KB) Brett Merrick, 08/27/2017 05:48 PM

Screen Shot 2017-08-28 at 1.18.28 PM.png (92.5 KB) Brett Merrick, 08/27/2017 08:19 PM

Screen Shot 2017-08-28 at 1.21.19 PM.png (112 KB) Brett Merrick, 08/27/2017 08:21 PM

History

#1 Updated by Kill Bill 10 months ago

Hmmm, wraps into multiple lines just fine here.

#2 Updated by Kill Bill 9 months ago

Wraps just fine without any CSS, as seen on the screenshot. Close, please.

#3 Updated by Kill Bill about 2 months ago

As noted above, wraps and works just fine on multiple boxes with Chrome, nothing invisible anywhere.

#4 Updated by Jim Pingle about 2 months ago

  • Status changed from New to Resolved

#5 Updated by Brett Merrick about 2 months ago

Sorry, latest version and issue still exists:

Looks like the issue might be the list of PFBlocker lists has no space in it?

#6 Updated by Kill Bill about 2 months ago

Huh? This bug is about ACB.

#7 Updated by Brett Merrick about 2 months ago

Sure,

ACB has a problem displaying messages with long strings of text without spaces.

PFBlocker generates messages that contain long strings of text without spaces.

I have suggested a fix that will accommodate any package that generates messages with long strings of text without spaces by allowing the message to "break-word".

Here is another example of a message that doesn't wrap, and with it a screengrab after the css is added.

#8 Updated by Kill Bill about 2 months ago

Yeah, you have suggested a fix for an issue that noone could reproduce due to bad description and the screenshots coming 15 months late. :-P

Besides, I'd say the issue would be better avoided by not using such craptastic format for log messages: https://github.com/pfsense/pfsense/pull/3809

#9 Updated by Jim Pingle about 1 month ago

  • Project changed from pfSense Packages to pfSense
  • Subject changed from AutoConfigBackup Restore Actions column missing to AutoConfigBackup Restore Actions column missing due to long XMLRPC sync merge strings in the configuration description
  • Category set to Backup/restore
  • Assignee set to Brett Merrick
  • Target version set to 2.4.0
  • Affected Version set to All
  • Affected Architecture set to All

Fixed description, PR was merged.

Also available in: Atom PDF