Project

General

Profile

Bug #637

Quality graphs are not generated for dynamic gateways until they are saved

Added by Jim Pingle about 9 years ago. Updated about 9 years ago.

Status:
Resolved
Priority:
Normal
Assignee:
-
Category:
RRD Graphs
Target version:
Start date:
06/01/2010
Due date:
% Done:

0%

Estimated time:
Affected Version:
2.0
Affected Architecture:

Description

If you have a dynamic WAN, it does not generate a quality graph until you edit the gateway and save. Presumably because there is no entry for a purely dynamic gateway in the config for the RRD code to use.

History

#1 Updated by Ermal Lu├ži about 9 years ago

I am not sure we should add this?
Most probably because stale files might occur if the gateway changes.

#2 Updated by Jim Pingle about 9 years ago

Many people will expect quality graphs to work "out of the box" with no extra work needed to set them up, especially in the default configuration of DHCP WAN.

I suppose when a gateway is renamed or deleted we could clean up the old RRD files to make sure the stale files don't pile up, but gateways probably won't change much.

I need to try to reproduce this again, however. I tried two days ago after a factory reset and it was making a quality graph like it should have. It may have been (inadvertently?) fixed since I originally noticed the behavior.

#3 Updated by Jim Pingle about 9 years ago

  • Status changed from New to Resolved

This is apparently no longer an issue. I can't reproduce it on a current snapshot. It must have been fixed incidentally by other fixes to the gateway code.

Also available in: Atom PDF