Project

General

Profile

Bug #6405

OpenVPN Server fails to start at boot when listening on v6

Added by Chris Malton over 3 years ago. Updated 2 months ago.

Status:
Not a Bug
Priority:
Normal
Assignee:
-
Category:
OpenVPN
Target version:
-
Start date:
05/26/2016
Due date:
% Done:

0%

Estimated time:
Affected Version:
2.3.1
Affected Architecture:

Description

On the latest update (2.3.1_1 - and also occurred on 2.3), when OpenVPN is set to listen on v6 only, it fails to start at boot with the error

May 26 10:55:15 gw-lon-gs2 openvpn12179: TCP/UDP: Socket bind failed on local address [AF_INET6]xxxx:xxxx:xxxx:xxxx::xxxx:yyyyy: Can't assign requested address

This appears to be because the IPv6 addresses haven't yet been assigned to the interfaces. If I then manually start the OpenVPN servers after the system has finished booting, it "just works" and I don't have to do anything special.

Hardware platform: amd64 (KVM Virtual Machine) using e1000 network cards

History

#1 Updated by Jim Pingle 2 months ago

  • Project changed from pfSense Packages to pfSense
  • Category set to OpenVPN
  • Status changed from New to Not a Bug

Old and misfiled. Resubmit if it's still an issue.

Also available in: Atom PDF