Project

General

Profile

Bug #6442

DNS Resolver - error

Added by Rene Schrauwen over 4 years ago. Updated almost 3 years ago.

Status:
Not a Bug
Priority:
Normal
Assignee:
-
Category:
DNS Resolver
Target version:
-
Start date:
06/02/2016
Due date:
% Done:

0%

Estimated time:
Affected Version:
Affected Architecture:

Description

Hello,

I'm getting the folowing error when I want to enable / save the DNS Resolver.
I've installed a fresh (VA) copy of the latest pfSense.

2.3.1-RELEASE-p1 (amd64)
built on Wed May 25 14:53:06 CDT 2016
FreeBSD 10.3-RELEASE-p3

<< Services - DNS Resolver - General Settings >>

"The following input errors were detected:
The generated config file cannot be parsed by unbound. Please correct the following errors:
/var/unbound/test/unbound_server.pem: No such file or directory
[1464876168] unbound-checkconf[1715:0] fatal error: server-cert-file: "/var/unbound/test/unbound_server.pem" does not exist"

History

#1 Updated by Chris Buechler over 4 years ago

  • Status changed from New to Feedback
  • Priority changed from High to Normal

not a replicable problem. That file is auto-generated by unbound's unbound-control-setup, which is run prior to testing whether the config is valid (which is what is failing from the missing file). Maybe it can't write to disk? No free space or a hardware problem would be the only reasons I can think of for that offhand. The resolver log may contain something useful.

#2 Updated by Chris Buechler over 4 years ago

  • Target version deleted (2.3.1-p2)

I can make this happen in Azure reliably because it fails to write files in some circumstance(s). It might also be an issue in Hyper-V in general. But it has nothing to do with DNS Resolver in particular, that problem of getting "access denied" when writing files is an occasional general problem with Azure which I'm tracking down separately.

Rene: you running in Azure or Hyper-V by chance?

#3 Updated by Rene Schrauwen over 4 years ago

Hi Chris,

Chris Buechler wrote:

Rene: you running in Azure or Hyper-V by chance?

I run pfSense on a VMware 5.1 host.
I can't replicate the error anymore after a re-install of the pfSense appliance.

#4 Updated by Chris Buechler over 4 years ago

  • Status changed from Feedback to Not a Bug
  • Affected Version deleted (2.3.1)

not a replicable problem outside problems writing to disk in general

#5 Updated by Joseph McGuirl almost 3 years ago

2.4.2-RELEASE-p1 (arm) on SG1000

"The following input errors were detected:
The generated config file cannot be parsed by unbound. Please correct the following errors:
/var/unbound/test/unbound_server.pem: No such file or directory

This occurs when:
DHCP Registration Register DHCP leases in the DNS Resolver IS CHECKED and
Static DHCP Register DHCP static mappings in the DNS Resolver IS NOT CHECKED

When both options ARE CHECKED there is no error

Also available in: Atom PDF