Project

General

Profile

Actions

Bug #6534

closed

DNS resolver doesn't returns AAAA records

Added by Luca Moncelli over 5 years ago. Updated over 5 years ago.

Status:
Not a Bug
Priority:
Normal
Assignee:
-
Category:
DNS Resolver
Target version:
-
Start date:
06/25/2016
Due date:
% Done:

0%

Estimated time:
Plus Target Version:
Release Notes:
Affected Version:
Affected Architecture:

Description

DNS resolver doesn't returns AAAA records.
From web gui: Diagnostics --> DNS Lookup
If FQDN has A and AAAA records result is A record only
If FQDN exclusively has AAAA records results is "Host could not be resolved."

This issue affect also aliases FQDN resolutions.

Actions #1

Updated by Kill Bill over 5 years ago

Unbound returns AAAA records just perfectly fine as you can see from shell (using host, drill or whatever). That page is using crappy PHP function without IPv6 support. https://bugs.php.net/bug.php?id=49493

Actions #2

Updated by Luca Moncelli over 5 years ago

oh.. maybe for the same reason is not possible to resolve ipv6 addresses in firewall log...

Actions #3

Updated by Chris Buechler over 5 years ago

  • Status changed from New to Not a Bug
  • Priority changed from High to Normal
  • Affected Version deleted (2.3.2)
  • Affected Architecture added
  • Affected Architecture deleted (amd64)

subject isn't true, there is a separate ticket for the DNS lookup page not supporting IPv6.

Actions #4

Updated by Luca Moncelli over 5 years ago

Resolved: now (tested on 2.3.2.a.20160630.1832) "Diagnostics / DNS Lookup" returns AAAA records.

Note: still on firewall logs ipv6 reverse lookup doesn't work.

Actions

Also available in: Atom PDF