Project

General

Profile

Bug #6595

Checking advanced DHCP config checkbox breaks option to ignore DHCP lease from specific IP

Added by Nash Kaminski over 3 years ago. Updated over 3 years ago.

Status:
Resolved
Priority:
Normal
Category:
Interfaces
Target version:
Start date:
07/10/2016
Due date:
% Done:

0%

Estimated time:
Affected Version:
2.3.x
Affected Architecture:

Description

When the advanced DHCP configuration option checkbox is checked for an interface setup as a DHCP client, such as the WAN interface, the config option to ignore leases from a certain DHCP server is no longer included in the actual DHCP server config file and therefore no longer has any effect. This change modifies the DHCP_Config_File_Advanced function to include the "reject x.x.x.x;" line if applicable in the advanced configuration as well. My proposed fix that I am currently using in my environment has also been submitted as Github PR #3054.

History

#1 Updated by Nash Kaminski over 3 years ago

This bug also appears to a regression from 2.2.x since the "DHCP Advanced configuration" option did not exist and the option to ignore leases form a particular IP worked properly.

#2 Updated by Chris Buechler over 3 years ago

  • Category set to Interfaces
  • Status changed from New to Confirmed
  • Assignee set to Chris Buechler
  • Priority changed from High to Normal
  • Target version set to 2.3.2
  • Affected Version set to 2.3.x

#3 Updated by Chris Buechler over 3 years ago

  • Status changed from Confirmed to Feedback

PR fixes, merged. leaving to confirm once it hits a snapshot

#4 Updated by Nash Kaminski over 3 years ago

Minor description correction: ...is no longer included in the actual DHCP server config file.. should read ...is no longer included in the actual DHCP client config file...

#5 Updated by Chris Buechler over 3 years ago

  • Status changed from Feedback to Resolved

fixed

Also available in: Atom PDF