Project

General

Profile

Actions

Bug #6670

closed

XMLRPC failure after setting proxy settings

Added by Antoine Rodriguez over 5 years ago. Updated over 5 years ago.

Status:
Not a Bug
Priority:
Normal
Assignee:
-
Category:
-
Target version:
-
Start date:
08/02/2016
Due date:
% Done:

0%

Estimated time:
Plus Target Version:
Release Notes:
Affected Version:
Affected Architecture:

Description

Hi,

environment : It's a pfsense HA for internal LAN firewalling. It does not have direct access to internet. In order to update it we had to set the proxy settings inside the advanced -> miscellaneous settings.

When we use proxy settings for packages or updates, the HA settings synchronization fails because it uses the proxy settings.

The error is : /rc.filter_synchronize: A communications error occurred while attempting XMLRPC sync with username admin https://XXX.XXX.XXX.XXX

When we remote the proxy settings the communication error is solved ...

Actions #1

Updated by Jim Pingle over 5 years ago

  • Status changed from New to Not a Bug
  • Affected Version deleted (2.3.1)

None of the XML_RPC_Client() calls we have specify a proxy, and I can't reproduce a problem here. When I specify a proxy on the master, the XMLRPC sync still succeeds.

Actions

Also available in: Atom PDF