Project

General

Profile

Bug #6921

Poor speed with Chelsio T420-CR

Added by Rajil Saraswat almost 3 years ago. Updated about 1 month ago.

Status:
Not a Bug
Priority:
Normal
Assignee:
-
Category:
Hardware / Drivers
Target version:
-
Start date:
11/11/2016
Due date:
% Done:

0%

Estimated time:
Affected Version:
2.3.2
Affected Architecture:

Description

I have a Chelsio T420-CR 10gbe NIC in a Supermicro A1SRi-2758f based pfsense router. I get poor speed (~1.2gbps) testing between the router and the desktop. The desktop has a Mellanox ConnectX-2 SFP+ card. The pfsense was setup with no customization with a WAN and a LAN (no packages installed).

The pfsense router was then wiped and replaced with FreeBSD-11. Testing again with the desktop, iperf3 this time showed ~9.5gbps speed as expected. Incidently, pfSense-2.4 snapshot also gives poor speed. I also booted the pfSense router in Arch Linux and again got ~9.5gbps speed.

It seems something is holding back T420-CR card in pfSense which is not an issue in FreeBSD-11.

History

#1 Updated by Jim Pingle about 1 month ago

  • Category changed from Interfaces to Hardware / Drivers

#2 Updated by Jim Pingle about 1 month ago

  • Status changed from New to Not a Bug

There isn't enough information here to prove a bug and it's been several years (and pfSense versions) since the initial report. Plain FreeBSD speeds won't have pf or other things enabled and are more optimized to work as endpoints, which is what you're testing, not throughput like you should. Post on the forum if you can still reproduce the problem on 2.5.0 snapshots.

Also available in: Atom PDF