Project

General

Profile

Bug #7334

SG-1000 Update failure

Added by Steve Beaver 4 months ago. Updated about 2 months ago.

Status:
Resolved
Priority:
High
Category:
Upgrade
Target version:
Start date:
03/01/2017
Due date:
% Done:

100%

Affected version:
2.4
Affected Architecture:

Description

Upgrade shows Failure notice after although it completes successfully.

Investigation has shown the upgrade script PID file is disappearing which leads the GUI to assume the upgrade is finished.

SG1000.jpeg (95.1 KB) Greg Siemon, 03/10/2017 11:50 PM

History

#1 Updated by Steve Beaver 4 months ago

  • Subject changed from SG-1-- Update failure to SG-1000 Update failure

#2 Updated by Renato Botelho 4 months ago

We experienced the same issue today on an APU board. Looks like GUI stopped tracking pfSense-upgrade json and considered upgrade has failed but it kept running in background as expected

#3 Updated by Steve Beaver 4 months ago

  • Assignee changed from Luiz Otavio O Souza to Renato Botelho

#4 Updated by Renato Botelho 4 months ago

  • Status changed from New to Feedback
  • % Done changed from 0 to 100

Fixed on pfSense-upgrade 0.18

#5 Updated by Steve Beaver 4 months ago

  • % Done changed from 100 to 50

I still see a failure on update as the PID file is deleted, but it now happens later in the update process.

>>> Updating repositories metadata... 
Updating pfSense-core repository catalogue...
pfSense-core repository is up-to-date.
Updating pfSense repository catalogue...
pfSense repository is up-to-date.
All repositories are up-to-date.
>>> Unlocking package pfSense-kernel-pfSense-uFW... done.
>>> Unlocking package pfSense-u-boot-ufw... 2.4.0.b.20170302.1426 version of pfSense is available
done.
>>> Downloading upgrade packages... 
Updating pfSense-core repository catalogue...
pfSense-core repository is up-to-date.
Updating pfSense repository catalogue...
== Failure message displayed ==

#6 Updated by Greg Siemon 4 months ago

Renato Botelho wrote:

Fixed on pfSense-upgrade 0.18

I'm still seeing 'failures' part way through the script. Screenshot attached...

The upgrade continues and the SG-1000 reboots with the latest update installed but there is no way to see what is going on except peering at the System Activity under Diagnostics.

BTW The Updates page on the SG-1000 doesn't show the update progress bar (red bar that fills up as each update package is downloaded) like I see on my VM installation. Not sure if this is another bug or by design on the SG-1000.

#7 Updated by Steve Beaver 4 months ago

  • Status changed from Feedback to Assigned

The progress bar issue is another matter. We are waiting for a fix from upstream.

#8 Updated by Renato Botelho 2 months ago

  • Status changed from Assigned to Feedback
  • % Done changed from 50 to 100

pfSense-upgrade 0.22 should fix it

#9 Updated by Renato Botelho about 2 months ago

  • Status changed from Feedback to Resolved

Fix confirmed

Also available in: Atom PDF